Showing results for 
Show  only  | Search instead for 
Did you mean: 
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 1 of 6

McAfee agent backward compatibility failed


I have attached the screenshot which shows that I am getting McAfee agent backward compatibility failed error.Everytime server reboots we get this error and we suspect because of this its effecting the services of other products installed.This service should not crash.We used agent as well as 5.5 also but it seems still we are getting this error.I am not sure if we need to try to use mcafee agent 5.6.Same error we are getting on many servers.

Can anyone let me know how to solve this issue?


Labels (1)
5 Replies

Re: McAfee agent backward compatibility failed

2020-01-27 02:41:32.854 macompatsvc(5672.12024) macompatsvc.Info: Starting Windows Service...
2020-01-27 02:41:32.858 macompatsvc(5672.12024) crypto.Info: Crypto logger used <00D27198>
2020-01-27 02:41:33.196 macompatsvc(5672.12024) crypto.Info: Setting of openssl in FIPS mode fails.
2020-01-27 02:41:33.198 macompatsvc(5672.12024) crypto.Error: OPENSSL: LIB=FIPS routines # FUN=FIPS_check_incore_fingerprint # REASON=fingerprint does not match
2020-01-27 02:41:33.198 macompatsvc(5672.12024) crypto.Error: Failed to initialize crypto library
2020-01-27 02:41:33.198 macompatsvc(5672.12024) crypto.Info: Crypto logger released <00D27198>

Re: McAfee agent backward compatibility failed

btw, I'm using Agent version 5.6.1

Re: McAfee agent backward compatibility failed

The logs above were from macompatsvc_<hostname>

Re: McAfee agent backward compatibility failed

Further experimentation reveals this issue in my case at least, is somehow related to Solidcore's state on the host (using If Solidcore status is either Enabled or Update, the above symptoms are experienced (i.e. failure). If Solidcore is Disabled or Observe, everything seems to work (i.e. the agent successfully communicates with all the endpoint software--ENS Platform/Threat Prevention/Firewall as well as Solidcore. 

Still no solution, but more detailed symptoms...

Re: McAfee agent backward compatibility failed

Here's more log info, this time from solidcore.log (solidcore was enabled at the time):

U.0592.2768: Jan 29 2020:15:08:21.021: SYSTEM: mapl_properties.cpp: 433: Function: mapl_get_properties.
K.4220.1540: Jan 29 2020:15:08:21.054: ERROR: umh.c : 977: Failed to open ntdll.dll. NTSTATUS = 0xc0000022.process_name: \Device\HarddiskVolume2\Program Files\McAfee\Agent\x86\macompatsvc.exe
K.4220.1540: Jan 29 2020:15:08:21.078: SYSTEM: vasr_hooks.c: 307: Relocating \Device\HarddiskVolume2\Program Files\McAfee\Agent\x86\libeay32.dll from adress 000000000FB00000 inprocess \Device\HarddiskVolume2\Program Files\McAfee\Agent\x86\macompatsvc.exe

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use our Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from product experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by employees.
Join the Community
Join the Community